Setup of CVB fails during installation

I tried to install CVB 13.00.000.
The setup always stops during the setup process.
At first, it looks ok but after decompressing the msi the setup dialog suddenly disappears.


is it possible to generate setup log? There are two ways to create those:

  1. When invoking the setup from the command line it is possible to pass options that will cause it to generate a log file. The following command line will generate a very verbose log into the file C:\cvbsetup.log:
   "CommonVisionBlox 13.00.000 (Win32).exe" /v"/L*v C:\cvbsetup.log"
  1. (356 Bytes) contains a registry file with which you can configure msiexec.exe to always generate a log file. The log files will be created in your %temp% directory and will be named like MSIxxxxx.log (where xxxxx is a sequence of lowercase characters and numbers). You’ll need to look at the file dates to identify the one that was created during the most recent installation attempt.
    (hint: If you don’t need log files during setup any more later one please remember to remove the registry entry created by MSILogging.reg, otherwise you %temp% folder will get bigger and bigger…)

Can you try this and have a look at the log if you see anything interesting? Typically around the region where the installation fails you’ll find the word “Failed” or “Rollback” - can you post the region from the log file where it begins to fail? (please try to avoid sending entire log files; they are easily 20+ MB in size and there is limited web space on the forum server)

I tried the two ways to create the log.
Both created no logfile at all.


We have happened upon a case that seems to fit your description so far during the release test phase of Common Vision Blox 13.00.000, where on some machines we saw the same behavior when trying to install the Win32 version of Common Vision Blox. On all machines where we encountered this it turned out to be our virus scanner: As soon as we temporarily disabled it the installation worked like a charm.

Do you have a virus scanner active on your machine? If so: Could you briefly disable it and then try to run the setup (don’t forget to reactivate it right afterwards!)?

Some background information

The Common Vision Blox (Win32|x64) 13.00.000.exe, our installer, is - although it is a huge file of almost 500 MB - in principle just a very small program (the rest of the file are just packed setup resources). What it does when you run it is this:

  1. Unless instructed otherwise via command line options (try "Common Vision Blox (Win32|x64) 13.00.000.exe" /? for a list of available command line options) this program opens a dialog in which it shows the user what’s happening. In silent mode (command line option /s) it will just perform the default actions.
  2. The program checks for potential prerequisites - packages that need to be present on the computer for Common Vision Blox to work properly. In version 13.00.000 these are the Sentinel SuperPro dongle driver (Win32 only), the CodeMeter Runtime (Win32 only) and the .Net 4.5 runtime. If these packages are not present, the setup.exe will offer to install them.
  3. Once the prerequisites have been installed the setup.exe will unpack the packaged MSI database into a sub directory of the %temp% folder and then pass it to msiexec for the actual Common Vision Blox installation.
  4. Once msiexec has finished, the temporary files will be removed and the setup.exe exits.

Our problem I mentioned before was that in step three the copy of the MSI file to the %temp% sub directly was created, but apparently the virus scanner prevented msiexec from actually using it. This is surprising because in principle it would/should have been possible for the scanner to access the packed information in the setup.exe and scan it - and it would/should have then been able to block already the access to setup.exe if it feels uneasy about its content. Why it instead chose to intervene much later at the stage where the MSI file is passed to msiexec is something I never understood.

1 Like

This was the solution. We use Kaspersky in our Office. After our IT disabled Kaspersky temporarily I was able to install CVB without any further problem.

Thank you very much for your Help.