Crash at CVB Management Console start

Hi everyone,

I am using CVB 13.00.002, 64 bit, Windows 7 (but I already had this problem with 13.00.000).
When I start the Common Vision Blox Management Console, the software crash when I click on “Device Configurator” and I have to kill the application to close it:

The log file give me this error:
!!!CRITICAL ERROR: unexpected standard exception caught, cannot continue, will rethrow, possibly crashing the process (Unable to load shared library)

I tried to delete the GenICam file to have a new one but it doesn’t help. I tried to reinstall CVB but I still have this problem.

I cannot start the GenICamBrowser neither.

Do you have any tips?
Thank you very much

Hi @MarionZ!

Can you cross-check what happens when you open the GenICam Browser, and what Transport Layers the GenICam Browser displays for your system?

Hi @illusive ,
I can’t select “Show/hide TLs…” beacuse when I start the GenICam Browser, I have directly the error message:

With those symptoms it’s very likely that an uncooperative Transport Layer (TL) is installed on the system. Transport Layers are enumerated by both, the Management Console’s Device Configurator and the GenICam Browser. Every TL found on the system will be used the the Browser/Device Configurator for detecting compatible devices. If, to put it neutrally, the :cvb: implementation of the GenApi and the TL are “on opposite ends of the standard” a crash is - unfortunately - a possibility.

There are ways to verify this and find out which TL is not cooperating with :cvb:, though. One possibility is to press the “Programm debuggen” (= “Debug program”) option on the second dialog if a development environment is available on the system. In that case, have a look at the call stack of the thread that raised the problem. In all likelihood you will find a module with a name ending in *.cti on top of the call stack. *.cti is the standard extension for TLs (for example the TLs installed by :cvb: are named CVUSBTL.cti and GevTL.cti). If you don’t have access to a development environment on that machine you can also produce a dump file and pass that on to a machine that has one or to us to analyze it.

Another option is to use the Dependency Walker and launch the GenICam Browser inside that tool (make sure you download the correct the architecture of the Dependency Walker) it will show which modules are being loaded - just look for the TL file that gets loaded right before the program fails.

Once the offending TL has been identified it usually suffices to rename the *.cti file so that :cvb: won’t find it any more (but keep in mind that other software you have installed might need it again later on…).

1 Like

There is also the option to check the involved TLs without debugging.
You can find the search paths for installed TLs in the environment variable GENICAM_GENTL64_PATH or GENICAM_GENTL32_PATH.

It is possible that you installed another SDK which installs there own transport layers (*.cti) and add the installation path to this environment variable.
e.g Vimba from Allied Vision or the Gocator SDK from LMI.

CVB uses this variable to register its TL path e.g. with:
C:\Program Files\STEMMER IMAGING\Common Vision Blox\GenICam\bin\win64_x64\TLIs

Check this environment variable if there is another path and look for *.cti files.
rename these files temporarily e.g. to * Then this TL will not be loaded anymore by CVB.

If you are able to start the Device Configurator or the GenICam Browser you found the TL which causes the crash.

1 Like

Thank you both for your help, you were right, I had a conflict with Sapera !