Error Message when launching Advanced Config in Management Console

#1

Hi,

as of now I used my private Notebook because I didnt had Administrator Privileges on my Work Notebook. That worked fine for some cameras, but for DALSA Cameras I need an Adapter with at least 1 GBit transfer which my private notebook just doesnt have.

Today I gained Admin Privileges and I could finally install the Common Vision Blox on my work notebook. The management console can start but as soon as I try to go to the Device Configuration and under Advanced Settings, an error message appears about a missing library: CVFactory.dll.
Image of error

In the Install Directory I found a CVFactory.cvb file and I noticed it is actually a DLL file. When renaming it to .dll it found the library, but didnt found entry points of some methods, so I undo that and now contact support.

Basically with a fresh installation this message appears and I dont know what to do.
The installation is the CommonVisionBlox 13.00.006 (Win32).exe

Thanks in advance.

#2

Hi @johmarjac

The Setup of the CVB 13.00.006 installs the correct version of the CVFactory.cvb and the AdvancedConfig.
Please try also the GenICam Browser which is our new Tool for Discovering and accessing GenICam compliant cameras and has even more functionality as available in the Management Console.
It is possible that it does not work ether.

Did you make an Update of an older CVB version ?
Was an old version installed before and you uninstalled it?
If yes, which version.

It should be enough to make a fresh installation of CVB. This means you uninstall cvb and go into the CVB installation folder. It should be empty or already removed. Otherwise delete all remaining files.
Restart the system and then install cvb again.

Regards
Sebastian

#3

I tried several things. Updating it told me that the older version first has to be uninstalled.

Uninstallting and installing it, didnt help. Restarting didnt help either.

Uninstalling CVB has completely removed the whole Installation Folder, no files remaining.

Very weird.

#4

Hi @johmarjac,

It really seems to be weird. But there has to be an explanation.
Can you contact our technical support please (support@stemmer-imaging.de).
Then we can try to make a remote session and take a look into it together what happens on your system.