Multi stream GigE vision camera through put is strange

Hello all,
I am working with a SW4000Q 10 GigE line scan camera that delivers RGB and NIR streams. So, using GeniCam broswer I tried to run only the RGB stream (DS0) and monitor the ethernet throughput. The through put shows a maximum of 9.5 Gbps. When I start the NIR stream (DS1), the through put remains unchanged. But, when I stop the NIR stream, the throughput falls to 7.0 Gbps.

When I started the DS0 stream, I was expecting the throughput to be at a smaller value and go up to maximum only when both the streams are running together but it looks like this is not the case here.
I am running the camera with RGB8 pixel format so ideally it should deliver only RGB images to DS0 and NIR to DS1. To confirm this, I tried the same setting from JAI eBUS Player and by running only the RGB stream, the through put of the camera was 7.0 Gbps.

Does the CVB driver load both the streams together when a stream is started from genicam browser ?

Hi @keerthitheja

from what I have heard we have seen similar beahviour in the past when JunkData gets enabled/disabled.

I will forward this, maybe @c.hartmann or @Andreas can jump in here as this seems to be an acquisition problem.


Can we call it ChunkData instead of JunkData? :smiling_face_with_tear:

1 Like

Haha sorry (not so) freudian slip :wink:


No, the GenICambrowser treats each stream individually.
And also ChunkData can’t be responsible, the data amount is tiny.

No ChunkData is not responsible, thats also not what I said.
What I said was, that @MandanaS reported similar behaviour with activating/ deactivating the ChunkData. Maybe she has more detail on this as I can only tell “from what I have heard”


Hi @Chris and @c.hartmann

I do not see this issue with Jai control tool or eBUS player. I see this only with the GenICam browser. Also, one more behavior I noticed is that at a maximum resolution of 4096 x 4096 and maximum line rate, the camera operates at 16 FPS. I tried to run the camera for 10 secs. So, ideally I should be receiving 160 images per each stream without writing the images to the disk. But, the total images received are around 80 to 90. Here I am not saving any images, I am just counting the total number of images received by the camera. At lower resolutions say 2560 x 2048, and maximum line rate, I get 33 FPS, but I do not see this behavior there.

This totally seems like an acquisition issue with maximum throughput.

@Chris using GenTL Stack acquisition, I activated und deactivated Chunk mode but that did not have any effect on payload size. That is of course not the source of the problem but could be the same effect.

Thank you for your clarification!