CVB not working on certain PCs

Hello,

I have the following problem:

I have currently CVB 13.01.002(x64) installed on 4 PCs. The problem is that it is only properly working on two of the four machines.
In all cases the camera is recognised by the GenICam Browser and displays the livestream correctly. However when I am trying to access the camera via one of the programms provided in the tutorial folder (specifically the VB.NET examples with the already compiled .exe files) on two of the machines the program is unable to open the GenICam driver.
I have no idea what could cause this weird behaviour.
The two machines on which everything is working correctly are:

  1. Windows 7 64bit Enterprise SP1, Intel Core i7 Q840 @1.87 GHz, 4 GB of RAM
  2. Windows 10 64bit Education, Intel Core i5-6500 @ 3.20 GHz, 16GB of RAM

The two machines where the tutorial programs are not working are:

  1. Windows 7 64bit Enterprise SP1, Intel Core i7-3520M @ 2.90 GHz, 4 GB of RAM
  2. Windows 10 64bit Enterprise (I don’t have the rest of the information on me right now, but I can get it should it be necessary)

I have also tried the newest Version of the CVB (13.01.006) on the machines that are not working with the same results.

Any ideas on where to look for the problem or how to fix this are greatly appreciated!!

Hi @frage12358,

bevore we dig deeper into this and start with error logging aso. I would like to know:
Are the systems identical in terms of installed software and SDKs?
Can you open the cameras in the ManagementConsole or the CVB Viewer on the machines that are currently not working?

Cheers
Chris

1 Like

Hi @frage12358,

If the camera is working in GenICam Browser, it is most likely, that the configuration of the GenICam driver is erroneous! Please double check if you did it correctly as follows:

  1. If you see the camera as a green icon, that means it has a proper IP address and is working (You can check that by double clicking it to get some live images)
  2. Click the “Add” button to add it to the list of configured devices
  3. The camera should now appear on the right side. These are the devices, that will later be accessible via the GenICam driver.
  4. Save the configuration.

By the way: the latest version of :cvb: is 13.2 :slight_smile: You can download it here in the Forum’s download section: https://forum.commonvisionblox.com/c/downloads

2 Likes