Problem with GeniCam.vin for CVB after Ethernet card replacement

#1

Hi Everyone,

For my research, I run a computer vision system comprising of the following:
Linux Ubuntu 14.04.01 - Kernel 3.13
CVB 12.01 - working fine until the event described below
Driver GeniCam.vin.1.801.13
Intel NC360T Dual Port for GigE interfacing
2x Dalsa Genie Nano-C1940 cameras

I have a setup running 2 Dalsa cameras described above and I use iCVCImg.h component of CVB to acquire raw images. A few weeks ago we had a hardware failure - our old I350-T2 adapter has failed. As a replacement we got the one specified above (Intel NC360T). Since then, the things started getting odd.

The “CVB GenICam Browser” recognizes both cameras. I can acquire images from them, configure their parameters etc. However, if I now try to run my routine acquiring the images, I encounter the following problem, calling the functions from the CVB toolkit:

TranslateFileName("%CVB%/drivers/GenICam.vin", driverPath,DRIVERPATHSIZE);
bool load_success = LoadImageFile(driverPath,*CVBObject);

the LoadImageFile returns 0, which means the driver initialization fails. Consequently, I cannot access my cameras. I have the path “%CVB%/drivers/GenICam.vin” set correctly. I tried updating my CVB version, but that didn’t help (I never got the 13.01 running on that setup, due to old kernel).

It is all particularly puzzling, since the “CVB GenICam Browser” works absolutely fine (with version 12.01) with the new hardware.

Would anyone here by any chance had any idea on what to look for or try out?

Thank you very much in advance for your help.

Jakub Sikorski

#2

Hi @j.sikorski

did you update your Configured Devices configuration after changing the network card?

A new network card means that you have a new MAC addresses for your NICs.
In terms of the GenICam.vin driver configuration a new Interface which is used to identify the device on your system.

If you did not remove your configured device in the GenICam Browser and added it again from the available devices you have the MAC address of the old network card in the configuration
To see the Interface MAC address of the configured device hover over it.
Then you should see:
Interface: SD::MAC->XX.XX.XX.XX.XX.XX

1 Like
#3

Hi Sebastian,

Thank you very much!

It was indeed that I forgot to update the configuration. After doing so, everything works like a charm again.