Unable to open gige camera

Hi all,
So, I am seeing another strange behavior with my area scan camera SP5000 CE. The camera doesn’t automatically show up in the genicam browser. Till last week it was showing up on genicam browser but today it did not (I haven’t been using the area scan for the past week).

When I do a ignore subnet discovery, the camera shows up and a green icon light up next to it. But, when I try to open the camera, the genicam browser crashes. If i add the camera to configured devices and then try to open, the camera icon shows a cross (x) mark and then camera icon in discovered devices goes red. I am seeing this for the first time. What could be causing this issue ?

Edit: I am able to ping the camera from the command prompt but unable to open it.
Also, I have connected a line scan camera along with it. The line scan camera shows up but the area scan doesn’t. Nothing was changed with respect to the network settings.

So, when I do discover in the genicam browser, only the line scan camera shows up but when I do ignore subnet discovery the area scan camera shows up. But, I am unable to open the camera. The camera IP’s are set to Automatic (Persistent Static IP).

Edit 2:
I tried opening the camera with JAI Control tool and it opens correctly. I know there is something foolish I am doing for the camera to be behaving this way.

So, Am I missing something important while using the GeniCam browser?

Would you please let us know your system specifications/platform? Are you using a VM? Which version of CVB are you using?

Hi @MandanaS

I am using Windows 10. I am not using any VM. I have connected the area scan camera using LAG connection. The version of my CVB is 13.04.006

Hi @MandanaS
Should I check by setting the IP of the camera manually ? Will that work ? Because when I open the camera with JAI control tool, it gives me a warning that multiple network interface cards are configured to have same subnet. So, should i change the subnet mask of the camera ?

Its strange that, I did nothing and today as soon as I turned on the PC, GeniCam browser detects both the cameras :sweat_smile:

1 Like

Well, thats good news I think :wink:
Lets hope it stays like that.

1 Like

@keerthitheja For this camera if you want to use the GigEVision LAG Functionality, you should Team two NICs on your PC and then preferably set a specific IP-Adresse for the new Joint-NIC. Your second Camera muss be connected to another NIC on the PC. I recommend to set a specific IP-Adresse for both NIC(The new Joint-NIC and NIC dedicated for the second camera) and avoid using DHCP, LLA connection and avoid any overlap between them.
Following commands demonstrate how to team two NIC unter windows (you should have admin rights):

PS C:\WINDOWS\system32> Get-NetAdapter

Name                      InterfaceDescription                    ifIndex Status       MacAddress             LinkSpeed
----                      --------------------                    ------- ------       ----------             ---------
Bluetooth-Netzwerkverb... Bluetooth Device (Personal Area Netw...     173 Disconnected A0-D3-7A-D2-FE-D2         3 Mbps
vEthernet (Ethernet)      Hyper-V Virtual Ethernet Adapter #3          89 Up           00-15-5D-87-7F-74        10 Gbps
WLAN                      Intel(R) Dual Band Wireless-AC 3168          23 Disconnected A0-D3-7A-D2-FE-CE          0 bps
vEthernet (VirtualBox ... Hyper-V Virtual Ethernet Adapter #4         100 Up           00-15-5D-7B-8F-3A        10 Gbps
vEthernet (Default Swi... Hyper-V Virtual Ethernet Adapter             11 Up           00-15-5D-22-80-A8        10 Gbps
Ethernet 4                Intel(R) Ethernet Connection (2) I219-V      16 Up           70-85-C2-6F-96-99         1 Gbps
vEthernet (Ethernet 4)    Hyper-V Virtual Ethernet Adapter #2          77 Up           00-15-5D-A8-F2-8E        10 Gbps
Ethernet                  Marvell AQtion 10Gbit Network Adapter        14 Up           70-85-C2-6F-96-97         1 Gbps
vEthernet (Ethernet 2)    Hyper-V Virtual Ethernet Adapter #5         111 Up           00-15-5D-BF-27-D3        10 Gbps
VirtualBox Host-Only N... VirtualBox Host-Only Ethernet Adapter        10 Up           0A-00-27-00-00-0A         1 Gbps
vEthernet (WLAN)          Hyper-V Virtual Ethernet Adapter #6         122 Up           00-15-5D-65-24-10        10 Gbps
Ethernet 2                Intel(R) I211 Gigabit Network Connec...       7 Up           70-85-C2-6F-96-99         1 Gbps

PS C:\WINDOWS\system32> New-NetSwitchTeam -Name "MyNICTeam" -TeamMembers "Ethernet","Ethernet 4"
PS C:\WINDOWS\system32> Get-NetSwitchTeam

Name    : MyNICTeam
Members : {Ethernet, Ethernet 4}

To remove a NIC Team, use:

Remove-NetSwitchTeam -Name "MyNICTeam"

Hi @MandanaS
thank you for the reply. The issue with the camera was I have already team the ports of area scanner for LAG. The issue is when I set different IP’s for the camera manually, the IP’s are getting rest to automatic once they are powered down. Is it possible to save the IP’s for the camera even after they are powered down ?

Yes, it is. Setting an IP persistent (static) means that after powering the device, the IP address will be the persistent IP address and does not need to be set manually again.

In GenICam Browser it looks like this:

Hi @MandanaS
I am trying to set the presistent IP, but that option gets grayed out once I set the IP. The dialogue box pops up again asking to me set up IP. When I set the IP Assign temporary IP (Force), it says please check if the IP is in correct subnet even though, the IP and the subnet mask of the camera and the NIC card is in same domain. Any suggestions on how to go about this ?

Do you have DHCP enabled on you NICs? If so, please assign them static IPs as well.

Hi ,
When you get the message “Please check if the device with IP x.x.x.x is in correct subnet”, that means the camera and the NIC are not in the same subnet.

Does it happen for the Jai camera with the Teamed NIC? In this case you can give us the IP-Address and subnet Mask of the Teamed NIC and the camera connected to it.

Hi @MandanaS
Yes. It happens to the Jai camera with Teamed NIC. The IP, I set to the camera was and the subnet is At the Teamed NIC port, the IP was set to and the subnet mask to

For my line scanner, I was able to set the persistent IP and it works but for area scanner, it fails all the time

Hi , if you set the IP-Address of the camera to, it would work and you can set it to persistent.