GenICamBrowser not showing any device

discovery
genicam
browser
#1

Hi,

I can put only 1 image per post so i’ll put links instead.

GenICamBrowser application is loading infinitely on “Discover devices” when I start it :

There is nothing in the list and the cursor is loading.

And all the icons are grayed out

The only way that I have to have access to 3 of those few options is to go to View -> Show / hide TLs… and click “OK”

Then :

And if i click on that second icon to ignore the subnet, it does nothing more than “Ready”…

The mouse cursor is always loading.

Here are my network interfaces:

enp0s31f6: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 20:46:a1:02:cd:6f  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 16  memory 0xdf600000-df620000

enp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.36  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::2246:a1ff:fe02:cd70  prefixlen 64  scopeid 0x20<link>
        ether 20:46:a1:02:cd:70  txqueuelen 1000  (Ethernet)
        RX packets 8157  bytes 1265634 (1.2 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8615  bytes 5020372 (4.7 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device memory 0xdf500000-df57ffff

enp4s0f0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 169.254.123.28  netmask 255.255.0.0  broadcast 169.254.255.255
        inet6 fe80::2c9c:3b8:2f7d:e620  prefixlen 64  scopeid 0x20<link>
        ether b4:96:91:24:cd:50  txqueuelen 1000  (Ethernet)
        RX packets 12698  bytes 18843070 (17.9 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 408  bytes 30885 (30.1 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device memory 0xdf300000-df3fffff

enp4s0f1: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b4:96:91:24:cd:51  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device memory 0xdf200000-df2fffff

enp4s0f2: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b4:96:91:24:cd:52  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device memory 0xdf100000-df1fffff

enp4s0f3: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b4:96:91:24:cd:53  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device memory 0xdf000000-df0fffff

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Boucle locale)
        RX packets 1460  bytes 311170 (303.8 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1460  bytes 311170 (303.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

ztrf23fe4s: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 2800
        inet 10.147.17.56  netmask 255.255.255.0  broadcast 10.147.17.255
        inet6 fe80::94ac:5bff:fe6e:91ce  prefixlen 64  scopeid 0x20<link>
        inet6 fc19:5094:2ab:7a6a:55d::1  prefixlen 40  scopeid 0x0<global>
        ether 96:ac:5b:6e:91:ce  txqueuelen 1000  (Ethernet)
        RX packets 6325  bytes 454455 (443.8 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 5129  bytes 6018039 (5.7 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

The 2 cameras are on the enp4s0f0 interface.

And here is my /etc/opt/cvb/drivers/GenICam.ini file :

[SYSTEM]
CreateAutoIni=0
StartupPort=0
NumCameras=2
[Channel_0]
TL=/opt/cvb/drivers/genicam/libGevTL.cti.1.1700.459
Interface=SD::MAC->B4-96-91-24-CD-50
Device=::ID->00-01-0D-C3-4A-A8::169.254.0.1
Vendor=Teledyne DALSA
Model=Nano-C4900
UserName=S1156987
SerialNumber=S1156987
MCMasterMode=0
MCSession=0
MCNoJoin=0
PacketSize=-1
InterPacketDelay=-1
PixelFormat=5
NumBuffer=3
RotateImage=0
ConvertAlways=0
AccessMode=4
AttachChunk=0
UseTurboDrive=0
[Channel_1]
TL=/opt/cvb/drivers/genicam/libGevTL.cti.1.1700.459
Interface=SD::MAC->B4-96-91-24-CD-50
Device=::ID->00-01-0D-C3-4A-AA::169.254.7.223
Vendor=Teledyne DALSA
Model=Nano-C4900
UserName=S1156989
SerialNumber=S1156989
MCMasterMode=0
MCSession=0
MCNoJoin=0
PacketSize=-1
InterPacketDelay=-1
PixelFormat=5
NumBuffer=3
RotateImage=0
ConvertAlways=0
AccessMode=4
AttachChunk=0
UseTurboDrive=0

I tried cleaning this file but it generates back when I open GenICamBroswer.

Can somebody help please ?

#2

I did not mention that the CPP program is working fine (except that it takes 1 photo instead of 10) :

#3

As said here Cannot start GenICamBrowser - libpng missing, I needed to add a few env vars to the .xsessionrc file :

CVB=/opt/cvb
GENICAM_GENTL64_PATH=/opt/cvb/drivers/genicam
CVGENICAM_REGISTRY=/var/opt/cvb/Registry
GENICAM_CACHE_V3_0=/var/opt/cvb/genicam
CVBDATA=/var/opt/cvb
CVBCONFIG=/etc/opt/cvb
#4

In order to avoid “regenerating” Genicam.ini: Replace the content with …

[SYSTEM]
CreateAutoIni=0

If the file is deleted a new file with …

[SYSTEM]
CreateAutoIni=1

will be created. And then any access to the .vin driver will start a discover over all interfaces (that means all transportlayers). Which then results in your devices being inserted in Genicam.ini.

2 Likes
#5

You may also run into an issue with services which are not running (because they are not called by debian).

siGevSvc ( needed for “ownership” to a Gige Camera, otherwise you will not be able to open them)
siLogSvc ( logging )
cvmgmtd ( our “management service” )

Should look like this:

user@chartmannX64:~$ ps -ef | grep cvb
root       798     1  0 09:39 ?        00:00:00 /opt/cvb-13.01.000/bin/siLogSvc -s
root       900     1  0 09:39 ?        00:00:00 /opt/cvb-13.01.000/bin/siGevSvc -s
root      1045     1 12 09:39 ?        00:00:03 /opt/cvb-13.01.000/bin/cvmgmtd
user      3037  3027  0 09:40 pts/0    00:00:00 grep --color=auto cvb

I’m confident that they are running for you ( you are able to access a cam ).

3 Likes
#6
$ ps -ef | grep cvb
root       420     1  0 09:11 ?        00:00:19 /opt/cvb-13.01.002/bin/cvmgmtd
root       441     1  0 09:11 ?        00:00:34 /opt/cvb-13.01.002/bin/siGevSvc -s
root       449     1  0 09:11 ?        00:00:01 /opt/cvb-13.01.002/bin/siLogSvc -s
user      1771   826  5 09:12 ?        00:15:06 /opt/cvb/bin/GenICamBrowser
user      5574  1439  0 13:42 pts/0    00:00:00 grep cvb

Yes indeed I can access a cam and configure options etc. Problem solved, thanks again.