Random Crashes Whilst Using Minos

Hi All,

We are having a bit of trouble with the Minos side of the teach bench at the moment…it will randomly crash out on us (when I say we and us this is happening on multiple different machines).

I have emailed the support team about this, but not sure if they are picking it up because I haven’t had a reply back from the last one, which was around a week ago.

After a crash, the windows event viewer does log a .NET runtime error, see the full exception below;

-------------------------------------------------------------------------------------------------------------------------------------
Application: TeachBench.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.NullReferenceException
   at TeachBench.Minos.ViewModels.TrainingSetViewModel.PerformConsistencyCheck(ImageInfo)
   at TeachBench.Minos.ViewModels.TrainingSetViewModel+<>c__DisplayClass227_0.<AddImageToTrainingSet>b__0(System.Object)
   at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(System.Object)
   at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()
   at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()
-------------------------------------------------------------------------------------------------------------------------------------

After the exception has happened once, it does tend to start to happen more frequently once restarting the teach bench. After another user of the teachbench reported the crash was happening more frequently I took a look at their event viewer and a different exception was thrown by the looks of it, see that one below;

-------------------------------------------------------------------------------------------------------------------------------------
Application: TeachBench.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.AccessViolationException
   at Stemmer.Cvb.MinosLib.MTSImageCheck(IntPtr, Double, Int32, Stemmer.Cvb.Minos.CheckProgressCallback, IntPtr, IntPtr ByRef)
   at Stemmer.Cvb.Minos.TrainingSet+ImageInfo.CheckConsistency(Double, Double)
   at TeachBench.Minos.ViewModels.TrainingSetViewModel.PerformConsistencyCheck(ImageInfo)
   at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()
-------------------------------------------------------------------------------------------------------------------------------------

We are currently using the latest version of CVB 13.02.003 and have tried both 32bit and 64bit versions.

Do you have any other suggestions that we can try?

Thanks

Hi @JoshSmith,

unfortunately we are still not able to reproduce this error…
Can you give us a more precise info of when the “random” crashes happen? Is it truly random and it crashes even if mouse and keyboard aren’t touched? Or does it only happen when you perform specific actions in the TeachBench, like selecting an image or (as described in your first report) rotating one?

For a more in depth investigation of your problem, we will need your Minos Training Set (.mts).

A crash dump of the TeachBench could also be helpful: https://helgeklein.com/blog/2018/10/creating-an-application-crash-dump/

Hi @rtp_derahs,

Sure, the crash usually happens a couple of seconds after adding a model to the training set, however the timing up to that point is random…so its not always after the 5th model taught etc…

I have sent an update regarding the rotational error to the support team. It seems very odd but the following seems to have solved my problem, before I was using the ‘RBG To Mono’ tool within the TeachBench to convert the images to greyscale, this is when I was getting the errors. A colleague suggested using InfranView to batch convert our set of images to greyscale before bringing them into the TeachBench to save a bit of time, and the error hasn’t appeared since…definitely a weird one.

Okay, I can send the training set over to you, is there a preferred place you would like it or just over email? I will also create a crash dump of the application for you and send that to you as well.

Thanks for your support.

Sounds pretty odd :thinking:
Over email is perfectly fine :slight_smile:

I have just sent an email to de.support@stemmer-imaging.com containing the training set and crash dump :slight_smile: :+1:

2 Likes

Okay, I was now able to reproduce the crashes when adding images to the trainig set, even though I have no explanation for that behaviour right now… I will let you know, as soon as we know more!
It looks like it only crashes when there is at least one model defined. It didn’t crash on my workstation without models.

In the meantime, I hope you can keep working with the TeachBench anyway!

1 Like

Are the images 8 bit per pixel? RGBToMono keeps the bit depth of the original color image (planes). It might be that Minos only works with 8bpp images.

@rtp_derahs Okay, that’s fine :slight_smile: We will keep working with it as best as we can, if there is anything we can do to try and reduce the crashes then let me know :+1:

Hi @Frank the images I am converting using the RGBToMono tool are 24bit…The images that come out of the InfranView converter are 8bit. Once I was using the IfranView images I saw no other rotation crashes within the polimago, I only saw crashes in the minos.

@JoshSmith
I attached the new dll with the bugfix.
TeachBench.Minos.zip (158.4 KB)

Cheers,
Tim

1 Like

@TStadler Thanks Tim, will let you know how it goes.

Hi @TStadler, I can confirm the fix is working well, no crashes as of yet!

Thanks for the support.

2 Likes