Problems with getting started

Hello there

Just to let you know I got not much experience in programming. I try to set up a JAI Camera for image aquiring. Now I am stuck in the Tutorial

This works fine:

image = cvb.Image("C:/Program Files/STEMMER IMAGING/Common Vision Blox/tutorial/Clara.png")"Clara.bmp")

m = cvb.as_array(image)

plt.imshow(m.transpose(), cmap="gray")


emu_device ="C:/Program Files/STEMMER IMAGING/Common Vision Blox/tutorial\\ClassicSwitch.emu")
stream =
device_image = emu_device.device_image
print("Resolution: " + str(device_image.width) + " x " + str(device_image.height))
print("Frames: " + str(stream.image_count))

But here I can’t start the Image aquisition:
vin_device ="C:/Program Files/STEMMER IMAGING/Common Vision Blox/drivers/")

It always returns:

  File "<ipython-input-16-ef46b32b4d05>", line 1, in <module>
    vin_device ="C:/Program Files/STEMMER IMAGING/Common Vision Blox/drivers/")

RuntimeError: {C-API call failed} ({LoadImageFileW})

Thanks for some input

I now solved this issue, there was a problem with the connection. But still I get no Images, just empty files.

Hi @stmoe

which version of :cvb: is installed and which operating system are you using?

I wonder how did you solve the problem of getting error “{C-API call failed} ({LoadImageFileW})”. I am currently experiencing exactly the same error when using function.

Hi @lxu,

loading the requires a camera to be configured in advance.
You can do this using the GenICam Browser. Otherwise loading the driver will fail.