GVCP Heartbeat Disable

Hello,

we are struggling with a Heartbeat timeout issue with our Teledyne DALSA Camera. In the Management Console, wanted to disable the GVCP Heartbeat Disable (Std::GevGVCPHeartbeatDisable) Parameter, but this particular Parameter seems to not be available, as can be seen in the image:

Is there some way we can still use this Parameter? Thank you for your help.

Best Wishes

1 Like

Hi @F_E,

what camera are you using exactly?
Also can you please try if you can set this parameter using the GenICam Browser?
You might need to set the Property visiblity to ‘Guru’.

Kind regards,
Tim

Hi @F_E,

I can see the exact same behaviour with a Dalsa Linea here.
Documentation says it should always be read/writeable .

I will check this with @M_M and keep you up to date.

Cheers

Hi @F_E,

can you tell us more about your heartbeat timeout issue (the reason why you want to disable the heartbeat)?

It is definitely not recommended to disable the heartbeat (thats the reason why it is greyed out). There are very few special cases where disabling the heartbeat is useful. Could you tell us more about your application?

For example, your application crashes. The hearbeat of the camera recognizes this, and takes care of disconnecting. With a disabled heartbeat, your camera keeps the state “busy”. In this case, restarting your application is not possible.

Best regards,
Martin

Hi, @TStadler, @Chris, @M_M ,

The Camera we are using is a DALSA Genie Nano-C2420 CS-Mount. I am also unable to set this parameter with the GenICam Browser.

The reason we are attempting to disable the Heartbeat is due to the fact that we are running into problems with automatic disconnects. The disconnect happens after the amount of milliseconds specified by Current Heartbeat Timeout (Std::GevHeartbeatTimeout). We tried increasing this Parameter, but it can only be increased to about 1minute – the next thing we tried is to disable the Heartbeat altogether. But apparently this does not really seem like a good workaround.

Best Wishes

Hi @F_E,

disabling the heartbeat seems to be a workaround. I recommend focusing on why you get disconnects. Besides the hardware like cabling please check also the network configuration (https://help.commonvisionblox.com/GenICam-User-Guide/html_english_nac_configuration_english.htm).

Some parameters of the camera are read only, that’s why you cannot change them. You can see those details in e.g. GenICamBrowser, when you select the parameter. Then you get detailed information on it like in the following example:

Best regards,
Bea

1 Like