GetCalibrationLists Not finding all the image dots

We have a system which uses a line scan camera to get a image from a round object as it spins.
We need to linearize the camera so we use an object with a 10mm X 10mm grid on, and create a transform using the points found with GetCalibrationLists.
This has worked fine before on multiple system but we now have one system where GetCalibrationLists is not finding a complete line in the image

This is the image and the red dots are where GetCalibrationLists has found a dot (ignore the green dots)

As you can see it does not find any dots on the second line down from the top
The parameters we are using for GetCalibrationLists are

style = CPS_Uniform_Dots
contrast = CPC_Black_On_White
aoi = full image
gridSpacing = 85 (have used 75 - 100 with no difference)
minContrast = 125 (Have used 32 - 175 with no difference)
maxRatio = 3 ( have used 1 - 10, anything above 1.3 finds all the points except the second row)

CVB version is 13.03.002 which we have used for a while now.
Does anyone have any idea why we are missing one complete line ?



That is indeed surprising. Can you upload or PM me the original image so that I can dig a bit deeper here?

thanks for looking at this.

This is the original image.

I was going to put it in the first post but I wasn’t allowed to add more than one link


Hi @Entire,

I think I got a fix for you. The trouble was caused by the approach for walking through the grid: The function would first try to establish a step width in x and y and then walk through the image starting in the center. In doing so, in up/down direction the deviation from the expected step size and the real one would be accumulated - and in you image in the 2nd row from the top this approach would end up just two pixels above the middle of the 1st and 2nd line - which leads to the 2nd line being skipped.

We have implemented an alternative that corrects this - you can download it here:

The linked downloads should work with without trouble (API and binary interface has not changed since then…). The change will become part of the upcoming 14.00.000 release of :cvb: - unless I hear from you that it’s not working well enough :wink:


Hi @Illusive

Thanks for the fix, I have quickly tried it on the system this morning and it seems to have cured the problem.

I will do some more testing next week, but its looking good at the moment :blush: