If IntelliSense is not working properly in VSCode, do this

If you happen to use CVBpy in VSCode and IntelliSense (auto-complete and documentation on mouse-over) is not working properly, then I might have a fix for you.

You’ve probably installed the extension “Visual Studio IntelliCode” (or had it installed at some point in the past). With this, a different IntelliSense engine will be used and default IntelliSense engines will be disabled. As a result IntelliSense with CVBpy does not work properly. If you mouse-over the type “Image” for instance, the result will look like:

grafik

To fix this, go to Settings in VSCode and search for “Jedi” and enable the engine. Then you have to reload VSCode.

grafik

Then, IntelliSense will work properly again with CVBpy:

From what I understand, if you still have the IntelliCode extension installed, VSCode will now use the new IntelliSense engine for other languages and “Jedi” for Python.

Alternatively, you could disable the line that disables Jedi in the settings.json (C:\Users<USERNAME>\AppData\Roaming\Code\User\settings.json) and thus enabling it again.

grafik

4 Likes