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This document aims to give recommendations towards the setup of Automation 

Technology C6 3D sensors on a general basis, while also addressing commonly asked 

questions regarding the installation itself or certain features of the device. As most of 

the information contained herein has been of practical interest in the past, it has been 

verified to work accordingly. Please note that the document is intended as 

supplementary to the documentation already provided by Automation Technology. If in 

doubt, the manufacturer should be considered as the authoritative source of 

information. 

Our mission is to provide the users and developers of imaging technology with 

competitive advantage by adding value in the supply of quality components, world-class 

vision expertise and support. With this manual, we want to help you to get your imaging 

system up and running as quickly and easy as possible – to strengthen the competitive 

advantage of your company. 
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1. Basic Information 

1.1. Purpose of this document 

This document aims to give a step-by-step instruction and recommendations towards the setup of Automation 

Technology 3D sensors. It guides a user to get the desired measurements and also addresses commonly asked 

questions and troubleshooting. As most of the information contained herein has been of practical interest in 

the past, it has been verified to work accordingly. Please note that the document is intended as supplementary 

to the documentation already provided by Automation Technology. If in doubt, the manufacturer should be 

considered as the authoritative source of information. 

1.2. C6 Sensors 

There are three different kinds of 3D sensors from Automation Technology. 3D Sensors (discrete setup), 3D 

Compact Sensors and Modular 3D Compact Sensors. All different types have already been available for the C5 

series. 

 

Figure 1: Different AT 3D sensors 

The 3D Sensors have a discrete setup so the camera and the laser line projector are separated. The setup is 

more complex but there is a high flexibility. For 3D Compact Sensors, the camera and the laser are built into a 

protective housing and they are pre-calibrated and focused. The Modular 3D Compact Sensors are positioned 

in between and combine the flexibility with the advantages of having a pre-calibrated and focussed system. 
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2. Get Prerequisits 

2.1. Hardware 

To get the sensor running, you need at least these hardware components: 

▪ AT C6 3D Sensor or (Modular) 3D Compact Sensor. 

▪ I/O Cable (M12, 17 pin), optional as pigtail cable or double sided M12 connector in combination with 

I/O-Panel. 

▪ GigE Interface Cable (M12). 

▪ Power Supply (12-24 VDC). 

▪ Optional: I/O Panel (Attention! Different I/O Panel for 3D Sensors and (Modular) 3D Compact 

Sensors). 

The IO-Panel is recommended because it provides a user-friendly and safer way to connect the power, I/O’s 

and laser supply of the sensor. The camera power supply also includes a reverse voltage protection and features 

a 2A micro-fuse. 

2.2. Software 

C6 Cameras of Automation Technology are compatible with all software that is supporting GenICam 1.2 or 

3.0 Standard. 

2.2.1. CX-Explorer 

The CX-Explorer is a graphical application by Automation Technology to configure all cameras, developed by 

the camera manufacturer, Automation Technology (AT). The CX-Explorer includes functionality that is tailored 

for the usage of 3D Cameras and offers special views and functionality to optimize your 3D Camera 

configuration. Configuring an initial setup, quickly change configurations and examine the practical 

consequences of different parameter sets is very handy in this application. 

The CX-Explorer is a proprietary application, free of charge and can be obtained by downloading the newest 

version of the cxSolutionPackage: https://www.automationtechnology.de/cms/en/support-packages/ 

2.2.2. Common Vision Blox 

Common Vision Blox is an image processing SDK, developed by Stemmer Imaging, which provides a variety of 

tools specialized on industrial vision applications. It has support for a considerable number of popular 

programming languages, e.g. C++, .Net, Python and platforms (Windows, Ubuntu (X64, ARM). 

Its architecture is based on a layered model: At the base, there’s a low-level part entirely dedicated to the 

integration of imaging hardware and basic data acquisition tasks. This is the CVB Image Manager. A level above 

are the CVB Tools, a collection of specialized algorithms for a variety of image processing tasks. Both layers 

can be used individually. 

The CVB Image Manager features a complete implementation of the GigEVision protocol. Furthermore, it 

comes with a GenICam API that’s particularly easy to handle. These two building blocks are already sufficient 

to develop a GigEVision application and to communicate programmatically with a GenICam device. Since 

version 13.03.000 CVB also supports MultiPart which is part of the GenICam 3.0 standard and is one key feature 

that the AT C6 cameras use to transmit image collections inside one buffer to the host system.  

https://www.automationtechnology.de/cms/en/support-packages/
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To support our customers optimally in developing their applications, a CameraSuite license is included with 

every GigEVision camera bought at Stemmer Imaging and is already integrated in every AT camera. The 

CameraSuite is a license that allows the usage of any Image Manager functionality as long as the camera is 

connected via Ethernet. 

Common Vision Blox (CVB) can be obtained via download from:  

https://forum.commonvisionblox.com/c/downloads 

2.3. Documentation 

The installation of the cxSolutionPackage brings a large number of different documents that can help 

integrating and understanding the cameras and their parameters. The AT documentation is located in the 

docs folder in the CX-Explorer installation directory. It includes the different sensor manuals, application 

notes for specific algorithms, a quick start guide for the cxExplorer and frequently asked questions as well as 

documentation for the cxSDK. The Browser- Documentary can easily accessed inside the cxExplorer GUI 

pushing the Help Button or online. https://docs.automationtechnology.de/ 

 

The full CVB documentation can be found in the Doc folder in the Common Vision Blox installation directory. 

The online help is available on this website: https://www.stemmer-imaging.com/s/solutions/common-vision-

blox-cvb?language=en_US. 

There is also the CVB User Forum with a lot of helpful information and the possibility to ask programming 

questions and get directly into contact with the developers: https://forum.commonvisionblox.com/. 
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3. Connect Sensor 

3.1. Hardware 

3.1.1. Basic Electrical Connection 

▪ Connect the sensor with the I/O board using the M12 I/O cable. 

▪ Connect the sensor with the PC’s network card using the M12 GigE interface cable. A Gigabit 

Ethernet Switch can be used in between as well, if needed. 

▪ Power the I/O board with a power supply (12-24 V DC). 

▪ Compact Sensors: Connect the laser supply on the I/O board with a power supply (5-24 V DC) 

3.1.2. Configure Network 

For more detailed information, also check our online GenICam User Guide:  

https://help.commonvisionblox.com/GenICam-User-

Guide/index.html?html_english_nac_configuration_english.htm 

It is crucial to correctly set up a number of networking parameters when using the high performance 3D 

cameras (and GigEVision cameras in general), in order to guarantee the expected performance. 

For the advanced configuration of the used port on the network card, the following parameters are of 

importance. Keep in Mind that Routing Hardware has to be configured too, e.g. a Network Switch 

▪ Jumbo Frames    9014 Byte 

▪ Receive Descriptors   2048 

▪ Transmit Descriptors   2048 

▪ Flow Control    Disabled 

▪ Optional: Interrupt Moderation Rate Extreme (for lowest CPU load) 

 

Figure 2: Setting Jumbo Packets in the advanced NIC settings 

https://help.commonvisionblox.com/GenICam-User-Guide/index.html?html_english_nac_configuration_english.htm
https://help.commonvisionblox.com/GenICam-User-Guide/index.html?html_english_nac_configuration_english.htm
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The network interface on the host machine can be either configured with a static IP address or by dynamic 

configuration. 

3.1.3. Set camera IP address and driver settings 

We recommend using the CVB GenICam Browser to set the sensor IP address of the 3D camera. After starting 

the GenICam Browser, you have to do an Ignore Subnet Discover  to find the sensor also with an IP address 

in a different subnet. Then click the Assign IP Button . You can use the Auto Select IP Button, to set a valid 

IP address automatically (see. Figure 3). You can also choose DHCP for a dynamic assignment. After clicking 

Set you can choose if you want to set the IP address statically. 

 

Figure 3: Set the camera IP address 

 

After setting the camera to a matching IP address, the camera will appear with a green icon and it is possible 

to communicate with the camera either in the GenICam Browser or in the cxExplorer. 

In order to use the camera in an automated software program of CVB, please configure the GenICam driver. 

Therefore, click the Add selected device button .  

Afterwards, click the Options button  to open the driver settings and optimize the acquisition settings. Set 

the Packet Size to 8192 to use jumbo packets. Set the CVB Color Format to Raw in order to receive 16Bit image 

data. The Interpacket Delay default value is sufficient for standard use case, but can be changed if required. 

Click Ok and the Save configured devices button . The CVB driver (GenICam.vin) is configured now. 
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Figure 4: Configure CVB vin driver 

4. Additional Information for discrete hardware setups 

This section is only for discrete 3D Sensors, where the camera and laser are separated and not delivered in a 

single housing. Users with a compact 3D sensor can skip this part. 

4.1. Choosing a Triangulation Geometry 

The foremost question on any laser triangulation task is the geometric configuration of laser and camera. 

Depending on their orientation, certain advantages for a particular type of inspection can be exploited, usually 

at the expense of some less important property. The possible choices regarding the triangulation angle are 

discussed in the sensor hardware manual. In practice, the most common setup is a 30° angle between camera 

and laser, where the laser is orientated perpendicular to the object plane. 

4.2. Mounting 

The main components should be firmly mounted with correct angle and distance. Refer to the laser manual, 

respectively the lens specification for correct focal lengths. To prevent excessive sensor temperatures, affixing 

the sensor on a heat-conductive mount is recommended. 

4.3. Optical Filters and Scheimpflug Adapter 

There are two common optical options to improve the image quality in a triangulation setup. If neither is 

relevant for the application, this paragraph can be skipped. The simplest one is to use a band pass filter to 

decrease the influence of ambient light. This is relatively effective due to the near-monochromatic properties 
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of laser illuminations used for triangulation. If you intend to use lenses with small F-values (< 25 mm), note 

that blueshift can occur at the corners of the lens. It might then be necessary to place the lens on top of the 

filter instead vice versa. Please contact us in case you are unsure if you are affected. 

However, ambient white light sources usually still emit a certain amount of light within the wavelength in 

question. The effect of this stray illumination must be countered by closing the aperture as much as possible 

or by protecting the whole installation from exterior light sources. It goes without saying that the maximum 

possible aperture reduction is proportional to the lasers intensity. Thus the said effect is decreasing with using 

higher laser intensities. 

Another measure to get an improved (i.e. sharper) line representation on the sensor is using a so-called 

Scheimpflug adapter. Any lens has a distinct plane where the optical imaging is optimal, depending on its focal 

length. Thus the imaging of object becomes gradually less sharp below and above that plane. As inspection 

objects commonly have features of different height, the laser line can only be imaged optimally at one height 

level, while the sharpness of the remainder is more or less satisfactory. 

The usage of a Scheimpflug adapter (also known as Tilt-Shift objective) counters this behaviour by tilting the 

lens plane relative to the sensor plane in a certain angle, which leads to a maximum sharpness in the plane of 

the laser sheet. The Scheimpflug angle can only be calculated if the triangulation angle and horizontal distance 

between laser and camera are known. 

4.4. Laser and Lens Alignment 

To adjust the camera optics and the laser/led laser line, the aperture should be opened to a maximum first. 

This aids in focussing the object plane, since differences in sharpness are much more visible. The lenses are 

best focussed when the laser line has the smallest possible line width. This can be easily checked with the line 

profile tool available in the CX Explorer. Please remember to activate the 16-bit mode to obtain a well 

resolved histogram. 

When the image and the laser line are sharp at the imaging area, the focus ring of the camera lens is best 

affixed by using the screw within the ring. 

 

Figure 5: Laser sharpness with line profile (defocussed in first, focussed in second image) 
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After finding the ideal focus of lens and laser, the aperture should be reduced again. Finding an appropriate 

aperture setting is crucial for a good triangulation system. Wide and narrow apertures have following 

different advantages, which should be taken into account when setting up the system: 

Wider aperture 

▪ Reduces interference from laser speckle 

Narrower aperture 

▪ Better depth of field (in case of the usage of a Scheimpflug adapter, this is neglectable) 

▪ Removes unwanted artefacts caused by exterior lighting 

Experiences show that normally a good compromise can be found when narrowing down the aperture about 

two increments. Nothing except the laser line should be visible at this point. 
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5. How to get a First Image 

This is a step-by-step instruction, to get a simple first 3D point cloud without any optimizations. 

5.1. cxExplorer 

• Open the cxExplorer and the sensor with the filter driver (FD). If no sensor is shown, see chapter 3.  

 

Figure 6: Open sensor in cxExplorer 

Hint: The siNetFilter Driver for GigE Vision technology is used to bypass the standard network stack 

(used by the operating system) for all data stream packets. It filters GigE Vision related data packets 

and transfers them directly to an application-provided data buffer. This greatly reduces the CPU load 

of the system and is therefore more efficient for image processing applications than the socket driver 

of windows. 

• To change the camera settings we recommend to use the XML pane (see Figure 7) and not the wizards 

to configure the camera. 

 

 

Figure 7: cxExplorer panes 
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5.2. Parameterizing the camera in cxExplorer 

Set these parameters in the XML pane (see Figure 7). 

1. Set The XML Panel access mode to “Guru”.  

 

2. Load the factory user set to make sure to start with the default settings:  

(User Set Control → User Set Selector → Default → Load User Set → Execute) 

 

3. By factory settings the camera will use Areascan mode to acquire the sensor raw image and no 

trigger will be set. Click the Live Image Button  to continuously acquire raw images from the 

camera.  

 

4. Position a non specular sample object in the laserplane at a distance specified inside the camera 

zRange from the datasheet. In the Image View Pane you should now see a white line describing the 

objects contour.  

 

Figure 8: Example for a live image in Areascan Mode. 

5. In Case you do not see the objects contour in the Image View Pane, check the working distance 

again. If the laser line is not visible, check if the laser is correctly powered (LSR Status LED is red) 

and if the laser is activated in the NodeMap: (Light Control → Light Controller Source → Exposure 

Active). Otherwise the object reflection might not be sufficient. Than Increase the Exposure Time 

(Acquisition Control → Exposure Time → Set Value) 

 

6. Optimize the Object positioning in the sensors FOV 
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7. Set the Pixel Format to Mono12p: (Image Format Control → Region Selector → Component Selector 

→ Pixel Format → Mono12p) 

 

8. Get a reasonably good laser line. A laser line is “good” if the signal-to-noise ratio between the 

laser line intensity and the intensity of the background is big enough. Hence, the best laser line 

intensity is a value close to the maximum (1023) – when at the same time the background is still 

close to zero. You can analyse the profile of the laser line with the Draw Line tool . Draw a line 

over your laser line and afterwards right click and choose New 2D LinePlot-View. The LinePlot View 

appears on the bottom. Press the Automatic Update button  to update the plot with every new 

image. 

 In order to improve the signal-to-noise ratio, you can 

a) adjust the laser line brightness by changing der laser intensity (Light Control → Light 

Brightness)  

b) or the exposure time (Camera Control → Sensor Control → Sensor Integration Time).  

Make sure to check different areas of your object with a different reflectance. Especially check the 

areas with the highest reflectance for saturation. 

 

Figure 9: Laser line with profile 

 

9. Set the AOI to the minimum required size on the sensor to optimize the acquisition speed. Either use 

(Image Format Control → Region Selector → Set Height and Offset Y) or use the AOI Selector  

from the Image View Pan and set the desired AOI with . 

 

10. Switch to Linescan3D mode to acquire full surface rangemaps and use line extraction methods. 

(Device Control → Device Scan Type → Linescan3D). 
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11. Use the Live Image Button to acquire a rangemap of a static surface. 

 

Figure 10: Rangemap of static surface 

 

12. Change the number of lines to acquire by changing the linescan3D image height (Image 

Format Control → Region Selector → Height). 

 

13. Set Acquisition Line Rate by activating the usage of a specific line rate (Acquisition Control → 

Acquisition Line Rate Enabled → True) and set the desired value (Acquisition Control → Acquisition 

Line Rate → Value) or use an Encoder by setting up the encoder parameters (Encoder Control → 

Encoder Selector → Parameters) and define it as line trigger input (Acquisition Control → Trigger 

Selector → Line Start → Trigger Mode → On). 

 

14. Activate the output of Reflectance and Scatter image (Image Format Control → Region Selector → 

Component Selector → Reflectance/Scatter → Component Enable → True). 

 

15. Change the line extraction method to Center of Gravity (Scan3d Control → Extraction Selector → 

Extraction Method → 3D Center of Gravity). 

 

16. Specify the coordinate scale in Z (Scan3d Control → Coordinate Selector → Coordinate Scale → 

Value). The minimum scale is limited by the available amount of bytes to represend sub pixel 

accuracy. A small AOI height allows the usage of a higher subpixel accuracy. To define the optimal 

value have a look on the more detailed description here: 

https://forum.commonvisionblox.com/t/switching-from-automation-technology-c5-to-c6-cameras-in-

cvb/1868/3 

 

 

https://forum.commonvisionblox.com/t/switching-from-automation-technology-c5-to-c6-cameras-in-cvb/1868/3
https://forum.commonvisionblox.com/t/switching-from-automation-technology-c5-to-c6-cameras-in-cvb/1868/3
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5.3. Reconstruct the point cloud 

The range map is an uncalibrated image of ranges. Objects closer to the camera have brighter intensities, 

objects further away have darker intensities. However, it is important to know that there is no information 

about metric values in x,y or z present. 

In some applications this kind of information is sufficient, e.g. for simple classification tasks, like if there is a 

scratch present in the object’s surface or not. However, if metric values are required (e.g. if it is important to 

know how big the scratch is in milimeters) a metric point cloud must be reconstructed using calibration 

parameters. For (modular) compact sensors there is a manufacturer created intrinsic calibration file already 

available on the sensor memory, while for discrete setups an intrinsic calibration needs to be performed first. 

 

1. Get the calibration parameters by loading the calibration file that is stored on the camera and 

includes the factory calibration. Therefore go to Device → Load/Save Calibration Metric... and click 

the button Load from Camera. 

If successful, the current calibration file will be displayed in the window, which means that it is 

available in the cxExplorer for future measurements. Further, if needed, the parameters can be 

written to a file on the PC. We recommend to save it in the .xml format, since it is readable. 

 

 

Figure 11: Load Calibration Parameters from Camera 
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2. Update the calibration parameters with the current settings of the machine, e.g. the resolution of 

the profile steps. Therefore, you need to edit the Sy value in the <extrinsic> section of the calibration 

file (.xml) and fill in your current y-resolution [mm]. This value depends on the speed of your 

movement or on the resolution of your encoder signals. 

 

Figure 12: extrinsic section of the camera calibration file 

 

3. To reconstruct the point cloud there are different ways available: 

a. cxExplorer: 

Once the calibration is present in the buffer of the cxExplorer, a point cloud is automatically 

reconstructed for each subsequently acquired range map. To display the point cloud within 

the cxExplorer, draw a rectangle onto the range map . By right-clicking you can create a 

3D display for this section (see Figure 13). Save the point cloud with File → Export Image. 

We recommend using the xyz- or ply-format, since it is readable and can be read by most 3rd 

party software. 
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Figure 13: Display Point Cloud in cxExplorer 

 

b. cxShow3D: 

A more convenient display of point clouds offers the tool cxShow3D of Automation 

Technology which is part of the cxSolutionPackage. First, save the calibration file (Device → 

Load/Save Calibration Metric… → Load from Camera → Save to File …) and range map 

(Select File → Save Image As Tiff… ) from the cxExplorer to the PC. Afterwards, load them 

into the cxShow3D software for a reconstruction of the point cloud. 
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Figure 14: Display Point Cloud in cxShow3D 

 

c. CVB: 

You can also create your own software to reconstruct and display point clouds using the 

SDK of CVB. For tests only you can use one of the tutorials available in the installation path 

(e.g. %cvb%\Tutorial\Image Manager\VB.Net\VBCore3D.NET).  

First, save the calibration file (Device → Load/Save Calibration Metric… → Load from 

Camera → Save to File …) and range map (Select File → Save Image As Tiff… ) from the 

cxExplorer to the PC. 

Afterwards, use RangeMap →Load Range Map and the GUI button Load Calibration to load 

the acquired data into the Core3D tutorial. Using the GUI button Generate Point Cloud the 

point cloud can be reconstructed and displayed (please set the radio button to Calibration 

File). 
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Figure 15: Display Point Cloud in CVB Core3D Tutorial 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


